Delay in ETH and ERC 20 Token Withdrawals
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Apr 16, 2024 - 13:23 EDT
Identified
Cryptocurrency deposits and withdrawals are currently delayed due to a technical issue with our hot wallet provider.

Our team is working to resolve the issue.
Posted Apr 16, 2024 - 12:32 EDT
This incident affected: Crypto Withdrawals (Ethereum - ETH, USD Coin - USDC, Bitcoin Cash - BCH, Apecoin - APE, Chainlink - LINK, Polygon - MATIC, AAVE - AAVE, Uniswap - UNI, SushiSwap - SUSHI, Decentraland - MANA).