e-Transfer Deposit and Withdrawal Service Interruption
Incident Report for Bitbuy
Resolved
This incident has been resolved. Any pending transactions will be completed shortly.
Posted Oct 05, 2021 - 19:23 UTC
Identified
Our team is aware of an issue affecting e-Transfer deposits and withdrawals and it is currently being investigated. e-Transfer deposits and withdrawals will be temporarily delayed until the issue has been resolved.
Posted Oct 05, 2021 - 16:43 UTC
This incident affected: Cash Withdrawals (e-Transfer Withdrawals) and Cash Deposits (e-Transfer Deposits).