Platform Maintenance
Incident Report for Bitbuy
Resolved
The maintenance has been completed and the platform is fully operational. Thank you for your patience.
Posted Oct 22, 2021 - 09:56 EDT
Monitoring
Please note that Bitbuy is currently down for maintenance. We expect the maintenance to be completed shortly and the platform will be fully operational. Thank you for your patience!
Posted Oct 22, 2021 - 09:15 EDT
This incident affected: Website and Mobile Apps (iOS App, Android App).