e-Transfer Deposit and Withdrawal Service Interruption
Incident Report for Bitbuy
Resolved
This incident has been resolved. Any pending transactions will be completed shortly.
Posted Sep 20, 2021 - 10:49 EDT
Investigating
Our team is aware of an issue affecting e-Transfer deposits and withdrawals and it is currently being investigated. e-Transfer deposits and withdrawals will be temporarily delayed until the issue has been resolved.
Posted Sep 20, 2021 - 10:35 EDT
This incident affected: Cash Deposits (e-Transfer Deposits) and Cash Withdrawals (e-Transfer Withdrawals).