Platform Maintenance
Incident Report for Bitbuy
Resolved
The maintenance has been completed and the platform is fully operational. Thank you for your patience.
Posted Oct 22, 2021 - 13:46 EDT
Monitoring
Please note that Bitbuy is currently down for maintenance. We are implementing a quick hotfix from this morning's deployment. We expect the maintenance to be completed shortly and the platform will be fully operational. Thank you for your patience!
Posted Oct 22, 2021 - 12:30 EDT
This incident affected: Website and Mobile Apps (iOS App, Android App).