E-Transfers Delayed
Incident Report for Bitbuy
Resolved
This incident has been resolved and e-Transfer deposits and withdrawals are fully operational. All pending transactions will be processed in the order they were received. If you are still waiting on a pending transaction to be processed, please email support@bitbuy.ca and we will assist you as soon as possible.
Posted Jan 11, 2022 - 15:50 EST
Identified
E-Transfers deposits and withdrawals may be delayed due to intermittent service interruptions with our banking provider.
Posted Jan 11, 2022 - 12:29 EST
This incident affected: Cash Deposits (e-Transfer Deposits) and Cash Withdrawals (e-Transfer Withdrawals).