LUNA Withdrawal Delays
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted May 12, 2022 - 17:29 EDT
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 15:20 EDT
Update
We are continuing to investigate this issue.
Posted May 12, 2022 - 12:47 EDT
Investigating
Cryptocurrency withdrawals may be delayed for the following coins: Terra Luna (LUNA)

The Terra Luna (LUNA) blockchain is experiencing degraded network performance. Please note this is a global issue and not isolated to Bitbuy.

We are monitoring the situation closely. Please note that LUNA deposits are temporarily suspended.
Posted May 12, 2022 - 09:28 EDT
This incident affected: Crypto Withdrawals (Terra Luna - LUNA) and Crypto Deposits (Terra Luna - LUNA).