Approximate CAD Value Calculation Issue
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Feb 03, 2023 - 09:47 EST
Investigating
The service that calculates the approximate Canadian dollar value of your balances is experiencing issues. This has no impact on the actual value of your holdings, and your funds are safe. Our team is looking into this and we expect to have it resolved soon.
Posted Feb 03, 2023 - 08:56 EST
This incident affected: Website.