Delay in Litecoin (LTC) Deposits and Withdrawals
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Oct 15, 2022 - 08:26 EDT
Investigating
We are currently investigating this issue.
Posted Oct 14, 2022 - 23:35 EDT
This incident affected: Crypto Withdrawals (Litecoin - LTC) and Crypto Deposits (Litecoin - LTC).