Connectivity Issues Due to Network Outage
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Jul 28, 2022 - 16:56 EDT
Investigating
Due to an outage with a service provider, access to Bitbuy is temporarily offline. We are monitoring the situation and expect it to be resolved shortly.
Posted Jul 28, 2022 - 14:36 EDT
This incident affected: Website and Mobile Apps (iOS App, Android App).