Issue Affecting New Signups

Incident Report for WonderFi

Resolved

This incident has been resolved.
Posted Nov 24, 2021 - 15:46 EST

Investigating

We are aware of an issue impacting new signups from being able to move forward with the process. We are currently investigating the issue and we expect it to be resolved shortly.
Posted Nov 24, 2021 - 14:31 EST
This incident affected: Verifications.