E-Transfers Delayed
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Jun 30, 2022 - 00:01 EDT
Investigating
E-Transfers deposits and withdrawals may be delayed due to intermittent service interruptions with our banking provider.
Posted Jun 29, 2022 - 21:33 EDT
This incident affected: Cash Withdrawals (e-Transfer Withdrawals) and Cash Deposits (e-Transfer Deposits).