Logins Impacted for Web browsers

Incident Report for WonderFi

Resolved

This incident has been resolved.
Posted Dec 19, 2025 - 14:55 EST

Investigating

We are currently investigating degraded performance for logins with certain browsers.

Some workarounds include clearing the browser's cache, switching temporarily to another browser, or using the Bitbuy mobile app as we continue to work on resolving the issue.
Posted Dec 19, 2025 - 14:08 EST
This incident affected: Website.