Increased Support Ticket Wait Times
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Apr 22, 2024 - 09:43 EDT
Investigating
With the recent market volatility our Customer Support team is experiencing extremely high volumes and response times are longer than usual. We appreciate your patience.
Posted Mar 04, 2024 - 09:25 EST
This incident affected: Customer Support.