Balance Loading Issue
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Jul 21, 2022 - 16:39 EDT
Investigating
We are aware of an issue with displaying certain users' balances. Balances are safe and our team is investigating the issue.
Posted Jul 21, 2022 - 15:13 EDT
This incident affected: Website and Mobile Apps (iOS App, Android App).