Delay in Cardano (ADA) Deposits and Withdrawals
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Jun 28, 2022 - 10:11 EDT
Investigating
We are currently investigating this issue.
Posted Jun 28, 2022 - 09:14 EDT
This incident affected: Crypto Withdrawals (Cardano - ADA) and Crypto Deposits (Cardano - ADA).