Delay in Bitcoin Deposits and Withdrawals
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Nov 14, 2022 - 20:01 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 14, 2022 - 19:40 EST
Investigating
Please note Bitcoin withdrawals are deposits are delayed due to a technical issue with our hot wallet provider. The issue is limited to Bitcoin only, and we expect it to be resolved soon. No funds are at risk, and all deposits and withdrawals will be processed as soon as the issue is resolved.

We appreciate your patience!
Posted Nov 14, 2022 - 18:15 EST
This incident affected: Crypto Withdrawals (Bitcoin - BTC) and Crypto Deposits (Bitcoin - BTC).