Cryptocurrency and e-Transfer Deposit/Withdrawal Service Interruption
Incident Report for Bitbuy
Resolved
This incident has been resolved. Any pending transactions that were affected will be completed shortly.
Posted Oct 20, 2021 - 16:44 EDT
Identified
Our team is aware of an issue affecting certain cryptocurrency and e-Transfer deposits and withdrawals and it is currently being investigated. All deposits and withdrawals will be temporarily delayed until the issue has been resolved.
Posted Oct 20, 2021 - 16:02 EDT
This incident affected: Cash Withdrawals (e-Transfer Withdrawals), Cash Deposits (e-Transfer Deposits), Crypto Withdrawals (Bitcoin - BTC, Bitcoin Cash - BCH, Ethereum - ETH, EOS - EOS, Litecoin - LTC, Ripple - XRP, Stellar Lumens - XLM), and Crypto Deposits (Bitcoin - BTC, Bitcoin Cash - BCH, Ethereum - ETH, EOS - EOS, Litecoin - LTC, Ripple - XRP, Stellar Lumens - XLM).