E-Transfers Delayed
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Nov 08, 2022 - 22:00 EST
Identified
E-Transfers deposits and withdrawals may be delayed due to intermittent service interruptions with our banking provider.
Posted Nov 08, 2022 - 20:17 EST
This incident affected: Cash Withdrawals (e-Transfer Withdrawals) and Cash Deposits (e-Transfer Deposits).