BTC Trading Temporarily Halted
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Jul 16, 2022 - 16:29 EDT
Investigating
The BTC-CAD market is temporarily halted while we investigate an issue. We expect this to be resolved shortly, thank you for your patience!
Posted Jul 16, 2022 - 13:48 EDT
This incident affected: Trading Engine.