Delay in Polkadot (DOT) Deposits and Withdrawals
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Jun 22, 2022 - 17:31 EDT
Investigating
We are currently investigating this issue.
Posted Jun 22, 2022 - 16:28 EDT
This incident affected: Crypto Deposits (Polkadot - DOT) and Crypto Withdrawals (Polkadot - DOT).