USD Coin (USDC) Warning
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Mar 13, 2023 - 10:12 EDT
Identified
Please note that due to issues with Circle's banking partners, the price of USDC is no longer trading at its intended peg of $1 USD. Before trading USDC, please ensure you understand the risks and are aware of the current market circumstances.
Posted Mar 11, 2023 - 09:26 EST
This incident affected: Website and Mobile Apps (iOS App, Android App).