e-Transfer Deposit Issue
Incident Report for Bitbuy
Resolved
The issue has been resolved. If you have a pending e-Transfer, please send a reminder through your online banking platform, or cancel it and resend. Apologies for any inconvenience this may have caused.
Posted Nov 21, 2021 - 13:14 EST
Investigating
We are currently investigating an issue affecting e-Transfer deposits. e-Transfer deposits will be delayed until the issue has been resolved. Thank you for your patience.
Posted Nov 21, 2021 - 10:48 EST
This incident affected: Cash Deposits (e-Transfer Deposits).