E-Transfers Delayed
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Nov 02, 2022 - 17:27 EDT
Identified
E-Transfers deposits and withdrawals may be delayed due to intermittent service interruptions with our banking provider.
Posted Nov 02, 2022 - 12:01 EDT
This incident affected: Cash Withdrawals (e-Transfer Withdrawals) and Cash Deposits (e-Transfer Deposits).