e-Transfer Deposit Delay For Certain Users
Incident Report for Bitbuy
Resolved
This incident has been resolved. If your e-Transfer deposit is still pending, you will see it deposited to your account shortly.
Posted Apr 21, 2023 - 09:35 EDT
Investigating
We are aware that certain users are experiencing delays in e-Transfer deposits. Our team is investigating the issue.
Posted Apr 20, 2023 - 13:20 EDT
This incident affected: Cash Deposits (e-Transfer Deposits).