Delay in Certain Cryptocurrency Deposits and Withdrawals
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Mar 09, 2023 - 20:18 EST
Identified
Cryptocurrency deposits and withdrawals are currently delayed due to a technical issue with our hot wallet provider.

Our team is working to resolve the issue. All user funds are safe, and deposits and withdrawals will be processed once the issue is resolved.
Posted Mar 09, 2023 - 18:32 EST
This incident affected: Crypto Deposits (Bitcoin - BTC, Ethereum - ETH, USD Coin - USDC, Solana - SOL, Cardano - ADA, Stellar Lumens - XLM, Polkadot - DOT, Dogecoin - DOGE, EOS - EOS, Litecoin - LTC, Bitcoin Cash - BCH, Apecoin - APE, Chainlink - LINK, Polygon - MATIC, AAVE - AAVE, Uniswap - UNI, SushiSwap - SUSHI, Decentraland - MANA) and Crypto Withdrawals (Bitcoin - BTC, Ethereum - ETH, USD Coin - USDC, Solana - SOL, Cardano - ADA, Stellar Lumens - XLM, Polkadot - DOT, Dogecoin - DOGE, EOS - EOS, Litecoin - LTC, Bitcoin Cash - BCH, Apecoin - APE, Chainlink - LINK, Polygon - MATIC, AAVE - AAVE, Uniswap - UNI, SushiSwap - SUSHI, Decentraland - MANA).