Issues cancelling Pro Trade orders

Incident Report for WonderFi

Update

We are continuing to investigate this issue. Please be aware that this issue is limited to Pro Trade orders placed before May 27, 2026 at 11:40 PM EDT.
Posted May 29, 2026 - 09:29 EDT

Investigating

We are currently investigating an issue where some Pro Trade orders cannot be cancelled.
Please contact our Support team if you are experiencing this issue: https://support.bitbuy.ca/hc/en-us/requests/new
Posted May 28, 2026 - 15:16 EDT
This incident affects: Trading Engine.