Delay in Certain Cryptocurrency Deposits and Withdrawals
Incident Report for Bitbuy
Resolved
This incident has been resolved.
Posted Nov 09, 2022 - 12:22 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 09, 2022 - 11:25 EST
Identified
Cryptocurrency deposits and withdrawals are currently delayed due to an ongoing technical issue.

Our team is working to resolve the issue.
Posted Nov 09, 2022 - 10:58 EST
This incident affected: Crypto Withdrawals (Bitcoin - BTC, Ethereum - ETH, USD Coin - USDC, Solana - SOL, Cardano - ADA, Stellar Lumens - XLM, Polkadot - DOT, Terra Luna - LUNA, Dogecoin - DOGE, EOS - EOS, Litecoin - LTC, Bitcoin Cash - BCH, Apecoin - APE, Chainlink - LINK, Polygon - MATIC, AAVE - AAVE, Uniswap - UNI, SushiSwap - SUSHI, Decentraland - MANA) and Crypto Deposits (Bitcoin - BTC, Ethereum - ETH, USD Coin - USDC, Solana - SOL, Cardano - ADA, Stellar Lumens - XLM, Polkadot - DOT, Dogecoin - DOGE, EOS - EOS, Litecoin - LTC, Bitcoin Cash - BCH, Apecoin - APE, Chainlink - LINK, Polygon - MATIC, AAVE - AAVE, Uniswap - UNI, SushiSwap - SUSHI, Decentraland - MANA).