Maintenance has been completed. Thank you for your patience!
Please note that you will only be able to cancel orders from 2:40 pm EDT until the marketplace reopens at 3:10 pm EDT. After the reopening, you can start placing new orders.
Posted Apr 28, 2025 - 14:42 EDT
Update
Scheduled maintenance is still in progress. We are working diligently to complete the process, and we will share updates on when services are expected to resume as soon as we have a clearer timeframe. Thank you for your understanding!
Posted Apr 28, 2025 - 12:10 EDT
Update
We appreciate your ongoing patience as we continue our maintenance, which is now expected to conclude at 12:00 pm EDT. Following this, only order cancellations will be permitted from 12:00 pm EDT until the marketplace reopens at 12:30 pm EDT. After the reopening, you will have the opportunity to place new orders. Thank you again for your understanding!
Posted Apr 28, 2025 - 11:46 EDT
Update
Thank you for your continued patience during our extended maintenance period, now scheduled to last until 11:30 am EDT. Once the maintenance is complete, please note that order cancellations will only be possible from 11:30 am EDT until the marketplace reopens at 12 pm EDT. After the reopening, you will be welcome to place new orders. Thank you for your continued understanding and support!
Posted Apr 28, 2025 - 11:11 EDT
Update
We sincerely appreciate your patience during this extended maintenance period, which will now continue until 11 am EDT. Once we complete the work, please keep in mind that you will only be able to cancel orders between 11:00 am EDT and when the marketplace reopens at 11:30 am EDT. After the reopening, you'll be able to place new orders. Thank you for your understanding!
Posted Apr 28, 2025 - 10:27 EDT
Update
The maintenance window has been extended until 10 am EDT. Once completed, please be aware that you will only be able to cancel orders from 10:00 am EDT until the marketplace reopens at 10:30 am EDT. After the reopening, you can start placing new orders.
We appreciate your patience and understanding as we continue with the maintenance process.
Posted Apr 28, 2025 - 09:04 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Apr 28, 2025 - 06:15 EDT
Scheduled
Bitbuy will be undergoing scheduled dealer maintenance on Monday, April 28, 2025 for 2 hours beginning at 6:15 am EDT. During the maintenance period, Pro Trade and Limit Orders will be unavailable, and users will be unable to place or cancel trade orders. You will still be able to access the platform, deposit, withdraw, and trade using Quick Trade.
We anticipate that service will resume at 8:15 am EDT. However, you will only be able to cancel orders from 8:15 am EDT until the marketplace reopens at 8:45 am EDT. After the marketplace reopens, you will be permitted to place new orders.
We apologize for any inconvenience this may cause and thank you for your understanding.
Posted Apr 23, 2025 - 16:23 EDT
This scheduled maintenance affected: Trading Engine.